Integrations are unavailable in PROD US and PROD IRL

Major incident Production IRL Integrations Production US Integrations UAT IRL Integrations UAT US Integrations
2023-09-20 12:00 UTC · 2 hours, 12 minutes

Updates

Post-mortem

Summary:

On 19th Sep 2023, our operations team observed an issue while monitoring integrations. Multiple EPs were found to be stuck in both PROD US and PROD IRL environments. After thorough investigation, the root cause was identified as a recent code change. The teams promptly implemented code changes to address and resolve the issue.

Customer Impact:

End users reported delays in EP’s, affecting their operations and causing disruptions.

Root Cause:

A software bug, introduced with a recent change, led to integrations getting stuck in processing.

Remediations:

A code fix was deployed to resolve the issue.

Future Mitigating Actions:

Enhanced change management processes specifically focusing on validation and production environment policies.

October 19, 2023 · 07:52 UTC
Resolved

We have confirmed internally and with our customers that the Aera platform is now fully restored.

We appreciate your patience during this incident and apologise for any inconvenience that this issue may have caused. Our teams are now working on documenting a comprehensive root cause analysis which we will share with you shortly.

If you have any questions or experience any further problems please don’t hesitate to reach out to our Support team at support@aeratechnology.com

September 20, 2023 · 14:11 UTC
Investigating

We are continuing to investigate the integration issues. Our engineers are actively working to restore service as quickly as possible. Thank you for bearing with us whilst we work through these issues.

September 20, 2023 · 13:46 UTC
Issue

This notice is to advise you that we are receiving reports of our customers experiencing difficulties with the Integrations. We are actively investigating and will provide regular updates until the issues are resolved.

Our apologies for the inconvenience this may be causing and we appreciate your patience as we investigate further.

September 20, 2023 · 12:27 UTC

← Back