Aera Platform is unavailable

Major incident Production IRL Platform Access Analytics Cognitive WorkBench Cortex Data WorkBench Discovery Integrations Other Features Skills Production US Platform Access Analytics Cognitive WorkBench Cortex Data WorkBench Discovery Integrations Other Features Skills UAT IRL Platform Access Analytics Cognitive WorkBench Cortex Data WorkBench Discovery Integrations Other Features Skills UAT US Platform Access Analytics Cognitive WorkBench Cortex Data WorkBench Discovery Integrations Other Features Skills
2024-10-23 23:00 UTC · 7 hours, 6 minutes

Updates

Post-mortem

Summary:

On 23rd October, internal monitoring indicated a service disruption, impacting user access to the Aera platform. Users were unable to successfully log in to the platform however integrations and agents were unaffected. The disruption was narrowed to an issue within the UI layer caused by a dependency on a third-party component which was experiencing an outage. Engineering teams identified a remediating fix that was deployed to all environments subsequently restoring full functionality.

Customer Impact:

Users were unable to login and access the Aera platform. However, integrations and agent access remained unaffected

Root Cause:

The Aera user interface was impacted by a dependency on a third-party component that was experiencing service unavailability.

Remediations:

Our technical teams implemented a fix that removed the dependency, subsequently allowing platform functionality to return to normal.

Future Mitigating Actions:

  • We have strengthened our monitoring systems to proactively identify and alert potential issues related to third-party components.
  • We have explored alternative solutions to reduce reliance on single-vendor components and mitigated risks associated with vendor-specific issues. The identified solutions have been added to the product roadmap.
November 1, 2024 · 10:11 UTC
Resolved

We have confirmed internally and with our customers that the Aera platform is now fully restored.

We appreciate your patience during this incident and apologise for any inconvenience that this issue may have caused. Our teams are now working on documenting a comprehensive root cause analysis which we will share with you shortly.

If you have any questions or experience any further problems please don’t hesitate to reach out to our Support team at Aera Support Portal

October 24, 2024 · 06:05 UTC
Investigating

We are continuing to work towards restoring services. While some customers are already back online, our teams are focused on resolving the remaining issues. We will continue to keep you informed as the investigation progresses. We appreciate your continued patience whilst we work towards resolution.

October 24, 2024 · 03:44 UTC
Investigating

We are continuing to work towards restoring service for the reported issues. A subset of our customers have had their services restored, and our engineers are focused on resolving the remaining issues. We will continue to keep you informed as the investigation progresses. We appreciate your continued patience whilst we work towards resolution.

October 24, 2024 · 01:56 UTC
Investigating

We are continuing to investigate the Aera Platform issues. Our engineers are actively working to restore service as quickly as possible. Thank you for bearing with us whilst we work through these issues.

October 24, 2024 · 00:34 UTC
Issue

This notice is to advise you that we are receiving reports of our customers experiencing difficulties with the platform. We are actively investigating and will provide regular updates until the issues are resolved.

Our apologies for the inconvenience this may be causing and we appreciate your patience as we investigate further.

October 23, 2024 · 23:55 UTC

← Back