PRODIRL - Integration Delays

Major incident Production IRL Integrations
2025-04-29 13:00 UTC · 59 minutes

Updates

Post-mortem

Summary:

On 29th Apr, a subset of customers experienced slowness in integration processing within the next generation East US2 production environment.Certain internal platform services were not functioning as expected, which led to delays in completing integration tasks. The issue was promptly investigated, and key services were restarted as part of the recovery process. Following these actions, integration performance returned to normal.

Customer Impact:

Some users experienced slower integration processing in the East US2 production environment.

Root Cause:

The issue was caused by a disruption in internal platform services within the East US2 production environment.

Remediations:

Key services were restarted, restoring normal integration processing performance.

Future Mitigating Actions:

Refining existing processes and alerting to further accelerate detection and response times.
We have planned updates to the infrastructure architecture to further enhance fault tolerance, scalability, and resilience.
Plans have been submitted to the product roadmap to improve resilience across services dependent on infrastructure.

May 8, 2025 · 11:10 UTC
Resolved

We have confirmed internally and with our customers that the Aera platform is now fully restored.

We appreciate your patience during this incident and apologise for any inconvenience that this issue may have caused. Our teams are now working on documenting a comprehensive root cause analysis which we will share with you shortly.

If you have any questions or experience any further problems please don’t hesitate to reach out to our Support team at Aera Support Portal

April 29, 2025 · 13:59 UTC
Investigating

We are continuing to investigate the issues with Integration delays. Our engineers are actively working to restore service as quickly as possible. Thank you for bearing with us whilst we work through these issues.

April 29, 2025 · 13:41 UTC
Issue

This notice is to advise you that we are receiving reports that a subset of our customers are experiencing difficulties with the Integrations. We are actively investigating and will provide regular updates until the issues are resolved.

Our apologies for the inconvenience this may be causing and we appreciate your patience as we investigate further.

April 29, 2025 · 13:15 UTC

← Back